Joomla! 2.5和Joomla! 3最大的区别是什么?

要说区别,最显著的好就是完全重构了后台UI,现在后台的设计相较Joomla! 2.5 更简单、更友好、更快捷方便,当然最主要的是引入了响应式框架(BootStrap),简单点说,界面会适应手机、平板电脑、PC等设备对应的尺寸,而且每种设备的UI都能发挥到极致。

此外,当然还有很多关于Joomla! 核心的改进,详细可参考Joomla! 3中的11大新特色,其中几个重点为:

  • Joomla! 3.x 新的安装程序!
  • Joomla! 3.x 引入了优秀的第三方框架,例如jQuery、Bootstrap框架
  • Joomla! 3.1 已经加入了Tag标签功能(掌声!期待已久)

每个Joomla! 的版本是怎么安排的?

Joomla!的每个发布版本都会支持长达4年,而且版本更新都支持一键更新,例如Joomla! 2.x(包含了1.6和1.7的过渡版本)的支持时间就是2011年-2014年12月31日,1.6到1.7是一键升级,1.7到2.5也是一键升级(Joomla 1.7升级至2.5,1.7模板可直接使用),2.5正式支持版本当然必须是一键升级(领略强大的Joomla!一键更新),这样一个长周期,包括过渡版本,都是让开发者、用户能够平衡过渡到未来的新版本。

Joomla! 3.x 自然也是经历4年的生命周期,3.0到3.1再到3.2都是7个月的生命周期,然后最后将以Joomla! 3.5为正式版本,目前计划2014年3月直到2016年,同上一代版本一样,Joomla! 3.x内部的各个版本都是支持一键更新,和2.x一样,这样一个长周期,也是为了让2.x的老用户、开发者能够有足够的时间能够过渡到3.x,并为4.x做准备。

正因为这样一个稳定的主要版本生命周期,用户才能顺利的从当前的主要版本过渡到下一个主要版本,编者注:官方似乎不将1.5视为一个长期支持版本,毕竟2.5+才算是真正的产品吧。

我计划做一个全新的网站,Joomla! 2.5和Joomla! 3如何选择?

大多数新网站,以Joomla! 3作为主要程序确实为一个好的方案,毕竟未来从Joomla! 2.5跨版本升级Joomla! 3要比Joomla! 3内部升级显得麻烦的多,你总需要考虑一下扩展和模板的兼容性,更重要的是3.x支持到2016年。

不过当前正式支持的长期版本是Joomla! 2.5,我们的建议是如果不需要使用Joomla! 3的新功能,还是建议使用当前的Joomla! 2.5,在使用Joomla! 2.5建站前还是需要为你的网站未来考虑,比如当前自己开发的扩展、模板都需要计划为Joomla! 3.x做兼容,大家需要放心的是,Joomla! 2.5到Joomla! 3.5升级虽然是跨版本升级,我们还是提供一键升级的功能,扩展是否兼容,请参考下文中的“怎么找兼容Joomla! 3.x扩展”

如果我创建一个Joomla! 3的网站,怎样安装扩展呢?

是啊,其实很简单,很负责地的告诉你,你可以安装任何支持Joomla! 3的扩展,前往官方扩展中心Joomla Extension Directory (JED),查找你想要的扩展,只要该扩展有Joomla 3.x这个标识,通常都支持Joomla! 3.x,不过在安装之后,最好前往该扩展的开发者网站上了解详细的细节。。

上哪找Joomla! 3.x模板?

这个问题问的好,官方的原话是这样:大多数模板公司会很快提供适用Joomla! 3的模板,但是这是个时间问题,一般都会在Joomla! 3推出长期支持版本后发布,当然有些2.5的模板也可以在Joomla! 3中使用,不过可能会有一些问题或者需要自己修改的地方,这样的话最好和模板商沟通。

题外话,这是个老问题,老诟病!Joomla!的模板问题一直阻碍其在中国的发展,Joomla!相较于Wordpress算是新秀,Wordpress发展迅速,普及性广,所以Joomla!在中国还需要走很长一段路。

怎么找兼容Joomla! 3.x的扩展?

往官方扩展中心Joomla Extension Directory (JED),查找你想要的扩展,只要该扩展有Joomla 3.x这个标识,通常都支持Joomla! 3.x,不过在安装之后,最好前往该扩展的开发者网站上了解详细的细节。。

我的Joomla! 2.5扩展能在Joomla! 3.x上运行吗?

Joomla! 3.x和Joomla! 2.5的扩展平台做了一些微调,不过也只是一些很小的改动,组件、模板需要进行测试,而模块、插件应该是可以正常工作,如果作者不推荐使用老版本的话,还是建议不要尝试这样,比如支持1.5的扩展就不支持2.5,一般还是等开发者更新支持Joomla! 3.x的版本吧。

简而言之,能否运行还是取决于扩展本身,Joomla!项目旨在让二次开发变得简单,所以一般情况下,开发者也会推出更新版本。

我已经用Joomla! 3了,发现喜欢的扩展还是只支持Joomla! 2.5?

这是一个互联网从业者很头疼的事,冒然前进才发现有大量的BUG,所以做之前慎重选择,如果有条件的话可以和你喜欢的扩展的作者联系,国内目前原创开发较少,想和外国开发者联络更新事宜,建议准备好词典组织好英文。。。

接下文Joomla! 3常见问题(下)

除特殊标明文章转自第三方网站,文章均由JOOMLASK.COM原创提供
欢迎友情转载,请务必保留本文出处并引用本文链接: Joomla! 3常见问题(上)

智能搜索

支付宝官方话费充值

淘宝充值